Reports of lagging in RevolutionEHR
Incident Report for RevolutionEHR
Resolved
This incident has been resolved. Additional information will be provided in the post mortem
Posted Sep 25, 2023 - 13:13 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2023 - 11:24 CDT
Identified
We believe we have identified the cause of the issue and are working to confirm and resolve
Posted Sep 25, 2023 - 10:46 CDT
Investigating
We are currently investigating the cause of some recent reports of lagging in the system. We will provide an update here as soon as more information becomes available
Posted Sep 25, 2023 - 09:58 CDT
This incident affected: RevolutionEHR United States.