Issues logging into RevolutionEHR

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 10:52 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 09:50 CDT

Identified

The issue has been identified and log ins are being restored. Some users are already able to log in, but if you are not able to log in yet, please wait a few minutes and try again
Posted Apr 14, 2025 - 09:39 CDT

Investigating

We are currently investigating this issue.
Posted Apr 14, 2025 - 09:26 CDT
This incident affected: RevolutionEHR United States.