Trizetto is reporting issues with SFTP connection

Incident Report for RevolutionEHR

Resolved

From Trizetto:

Resolved - ALERT: Send and Receive File Errors: Tuesday, March 3, 2026
TriZetto Provider Solutions is aware that users may be experiencing slowness or errors when attempting to send and receive files via the client website today, Tuesday, March 3, 2026.

This issue is now resolved.

Thank you for your patience.
03/03/2026, 11:52 AM CT
Posted Mar 03, 2026 - 13:01 CST

Investigating

We are aware of an issue affecting TriZetto SFTP login functionality, which may impact users’ ability to submit claims and statements from RevolutionEHR to Trizetto. TriZetto is currently investigating the issue. We will provide updates as more information becomes available.
Posted Mar 03, 2026 - 10:07 CST
This incident affected: Integrated Partners.