Intermittent issues impacting RevolutionEHR phone lines for all departments

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:11 CDT

Monitoring

Reports from AWS indicate that services are gradually recovering. Our phone system appears to be operating normally at this time, and we will continue to monitor throughout the evening and into tomorrow morning to ensure the issue has been fully resolved.
Posted Oct 20, 2025 - 16:55 CDT

Identified

We are currently experiencing intermittent phone issues due to a known AWS outage impacting multiple major services. At times, our phones may connect normally, while other times you may have difficulty reaching us. AWS is actively working to resolve the issue.
Posted Oct 20, 2025 - 11:34 CDT
This incident affected: RevolutionEHR United States and RevolutionEHR Canada.