The failover has been completed and access to RevolutionEHR is restored. We will provide more information when we receive details from AWS. At this time there is still no ETA from AWS on the resolution of their issue but the failover allows RevolutionEHR to run on servers that are not impacted.
Posted Apr 16, 2025 - 20:02 CDT
Identified
We do not have any ETA from AWS on a possible resolution. In the interim we are working to perform a failover to promote a replica as the new primary database which will allow us to operate on an AWS server that is not currently experiencing degradation. This process can take 1 to 2 hours, but we will continue with this in the event that the AWS issue is not resolved soon.
Posted Apr 16, 2025 - 19:38 CDT
Update
We are currently seeing an AWS degradation of service in the us-2-east region which appears to be causing the current issue. We are working to confirm this and obtain additional information
Posted Apr 16, 2025 - 19:17 CDT
Investigating
We are currently investigating this issue.
Posted Apr 16, 2025 - 18:30 CDT
This incident affected: RevolutionEHR United States.