Attention US Customers: Delay in reports and claim status
Incident Report for RevolutionEHR
Resolved
All delays have been resolved
Posted Jul 31, 2023 - 16:16 CDT
Update
Current delay is approximately 10 to 12 minutes.
Posted Jul 31, 2023 - 15:17 CDT
Investigating
There is currently a delay of approximately 6 minutes as it relates to reports which also includes claim status. Any new data entered can take up to 6 minutes to appear in an associated report and any change in claim status will also be delayed. For example, authorizing an invoice may take up to 6 minutes for the claim to appear in the Claims to Submit list.
Posted Jul 31, 2023 - 14:33 CDT
This incident affected: RevolutionEHR United States.