Reporting Delay

Incident Report for RevolutionEHR

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 16:52 CDT

Update

Delays are down to approximately 4 minutes
Posted Mar 20, 2025 - 16:44 CDT

Investigating

There is currently a delay of approximately 15 minutes as it relates to reports also when adding inventory. Any new data entered can take up to 15 minutes to appear in an associated reports. For example, when receiving a payment or adding a new inventory item it may take up to 15 minutes appear. This does not impact claim status updates.
Posted Mar 20, 2025 - 15:59 CDT
This incident affected: RevolutionEHR United States.