Trizetto continues to experience intermittent issues with claims submission
Incident Report for RevolutionEHR
Resolved
This incident has been resolved.
Posted Jun 12, 2019 - 14:32 CDT
Identified
The following statement was provided by TriZetto:

TriZetto Provider Solutions is aware that users may be experiencing slowness or errors when transmitting claims. If a time out or error occurs, please try again later.

Due to send and receive file errors, clients may utilize the Alternate Send Method to submit claims by logging into the TriZetto website and navigating to the following:
On the home page under the Send and Receive menu:
Send/Receive Files
Switch to Althernate Send Methods
Browser for the file to upload
Posted May 16, 2019 - 15:50 CDT
This incident affected: Integrated Partners.