RevDirect Messaging
Incident Report for RevolutionEHR
Resolved
The RevDirect issue was identified and resolved.
Posted Feb 27, 2020 - 15:46 CST
Investigating
RevDirect is currently experiencing intermittent errors when sending messages. We will post an update once we have identified the issue.
Posted Feb 27, 2020 - 11:28 CST
This incident affected: Integrated Partners.